These community forums are free for anyone to use, they provide support for OpenUnderwriter related matters. Please note, you must register with the website and login to post messages and questions, this helps reduce spam.

Support Forum

  • Index
  • » Users
  • » dickanderson
  • » Profile

Posts

Posts

It looks like you have an error in the spreadsheet. Take a look at row 96. The error suggests that you are passing an extra parameter:

    CurrencyAmount(String, String, Currency)  is undefined.

CurrencyAmount only accepts two arguments.

Hope helps.

Regards,
Richard.

2017-01-17 10:24:17
on installing it gives me this error "MySQL does not appear to be running. Please check you...
Category: User Forums

When you start OU the run script performs a number of environmental checks before it starts the server proper. One of those checks is to make sure that MySQL is running and that its accessible. That checks failing here. What it actually does is to try and open a connection on the standard MySQL port (3306) and execute a test query.

The first thing I would do is to check that you do have MySQL installed and running and, if it is, confirm which port it is listening to.

Regards,
Richard.

2016-10-21 07:44:16
Difficulty with MySQL
Category: User Forums

Hi Keith,

It seems you are failing foul of one of the pre-condition checks which OU carries out before it starts the server proper. What it is actually doing is to test that it can open a connection to the database using the username/password supplied and the default MySQL port. As you are sure about the username/password, I would start by checking the port. The default port for MySQL is 3306. Maybe there is a firewall issue?

You could try the following from the command line as a basic access test. If you can login to mysql this way, OU should be fine:

mysql -u XXXX -p --host=127.0.0.1 --port=3306

Regards,
Richard.

If you could upload a copy of whatever you see on the console when you invoke run.bat to this thread I'll be happy to look into it.

Regards
Richard.

Hi jguaring, welcome to the forums.

The installation script uses the file [OU HOME]/tmp/setup to indicate that the DB script has been run and therefore not to run it again in future. If you remove this file, you should be up and running again.

Regards,
Richard.

Hi,
When OU runs for the first time it needs to create some databases in MySQL and populate them with data. To do that it needs to execute mysql. The error your getting is simply OU's setup script letting you know that it can't see the mysql command. Almost certainly this is because the MySQL bin folder isn't in the PATH.

The following link takes you though the process in detail: http://stackoverflow.com/a/23841529

I hope that helps.

Regards,
Dick.

2016-06-30 08:35:48
Installation stopped (multiple times) at 'deployed "sync-web.war"
Category: User Forums

Things look good until you get this message:

Caused by: com.liferay.portal.NoSuchUserException: No User exists with the primary key 10436

This suggests that the database has not initialised properly. When you install OU (just after prompting you for mysql root username/password) it creates and populates a number of databases in MySQL. Something has gone wrong in this step.

My first suggestion would be to double check that all of the steps in the installation notes related to MySQL. Especially this one:


If you are installing on a Linux based machine, edit /etc/my.cnf and add the following line to the [mysqld] section: 'lower_case_table_names = 1'

You would need to have restarted MySQL after making that change.

Regards,
Richard.

2016-06-29 20:40:08
Installation stopped (multiple times) at 'deployed "sync-web.war"
Category: User Forums

Hi
Ubuntu and 3.0 is a good combination. I suspect something else is going on. If you attach a copy of the server.log file to this thread, I'll take a look.

You can find the file here: [OU HOME]/liferay-portal-6.2.0-ce-ga1/jboss-7.1.1/standalone/log/server.log

Ta.,
Richard.

2016-06-29 16:10:07
Installation stopped (multiple times) at 'deployed "sync-web.war"
Category: User Forums

Hi,
We recommend using Oracle's JDK, OpenJDK will work for the most part but some document generation functions fail. JDK 7 is fine.

You can find some more notes on installation here: https://openunderwriter.atlassian.net/w … tion+notes. There are some important points in that doc specifically about unix installations which could save you a lot of head scratching.

Regards,
Richard.

2016-06-06 07:18:59
Unsuccessful?
Category: User Forums

Hi Toshi,

If you could attach a copy of your OU log file to this thread, I'll take a look.

The log file is in [OU HOME]/liferay-portal-6.2.0-ce-ga1/jboss-7.1.1/standalone/log/server.log.

Kind regards,
Richard.

2016-05-20 08:35:57
getAssessmentSheet cannot be reference in an aggregated policy. Use getAssessmentSheetFor() instead.
Category: User Forums

Hi Yoseph,

I've have your product now. Thanks.

I haven't tried running it, but I can see an immediate problem in the aggregator product's Registry.xml related to the service setup.

OU has the concept of services and commands. Services implement business logic of some kind and Commands define how client code gains access to a service. A service might be implemented as a java class, a web service, a Drools rule, a Janino class or whatever; and may be implemented differently in different products. The client code doesn't know, it accesses them all the same way - via a command.

The Base product (AIL/Base) defines the a set of Services and Commands which most products will need. All products inherit these definitions. The Base product actually maps CalculatePolicyCommissionRule to the NullService - meaning that it will do nothing when invoked unless a product overrides the definition.

The MotorPlus product which your product is based on does just that - it defines its own commission rules. As you don't want to use that service in this case you can simply delete it from the Registry altogether; removing the following lines from your Registry.xml will do the trick:

Code:


<service name="CalculatePolicyCommissionRule" builder="CachingClassBuilder" key="com.ail.core.command.JaninoAccessor">
            <!--parameter name="Url">~/JavaServices/CalculatePolicyCommissionRule.java </parameter-->
</service>

As I said, I haven't tried running the product but I'm pretty sure that this change will get you past the current problem. As you work on your product it is worth keeping the Base product in mind. You  might well find other similar issues which can be fixed the same way.

I hope that helps.

Richard.

2016-05-13 21:13:07
getAssessmentSheet cannot be reference in an aggregated policy. Use getAssessmentSheetFor() instead.
Category: User Forums

Hi Yoseph,
I've sent you a PM with details.

Regards,
Richard.

2016-05-13 06:37:32
getAssessmentSheet cannot be reference in an aggregated policy. Use getAssessmentSheetFor() instead.
Category: User Forums

Hi Yoseph,

Converting MotorPlus into an aggregator is perfectly possible, but will involve some product surgery. I wouldn't describe it as simple, but it is perfectly achievable.

If you could zip up your product as it stands and attach it here, I'll take a look. I think I can see what might be wrong, but I'll need to look at the product source to be sure.

Regards,
Richard.

2016-05-11 14:24:37
getAssessmentSheet cannot be reference in an aggregated policy. Use getAssessmentSheetFor() instead.
Category: User Forums

Hi Yoseph,
Are you getting the same exception as before or is it something different?

Assuming it is the same, it is possible that simply disabling Commission service in your aggregator will get you over the hump. Let me know, and we can look in it in more detail.

Regards,
Richard.

In addition to what Matthew suggested, you might also want to try the latest build. There have been a couple of fixes since the 3.0 release which improved the reliability of exactly this kind of process. The demo server is running a post-3.0 release, which might explain why it worked for you there.

You can grab the latest release binary from our build server here: openunderwriter-community-trunk.trunkb276.zip

Regards,
Richard.

2016-04-15 07:41:52
Bugs during Installation on server Ubuntu 10.04.4
Category: User Forums

Hi, Interesting that you mention Africa. We have seen a lot of interest from there which has lead to a number of projects. Drop us a line at contact@openunderwriter.com if you'd like to talk in more detail. We have contacts and partners who might be able to offer assistance.

Back to the error now. Could you upload a copy of the server.log file (you'll find it in [OU]/liferay*/jboss*/standalone/log)? This may help in a diagnosis.

Alternatively, you are more than welcome to use our demo server: demo.openunderwriter.com.

Kind regards,
Richard.

2016-04-14 16:00:04
getAssessmentSheet cannot be reference in an aggregated policy. Use getAssessmentSheetFor() instead.
Category: User Forums

Hi Yoseph,

Is this a product you are building yourself or the demo product?

The exception your seeing is caused by some part of the product trying to call policy.getAssessmentSheet(). This isn't valid in a aggregated product because in that situation the policy will contain many assessment sheets (one for each of the sub-products being quoted). You therefor have to use getAssessmentSheetFor(String productName) instead to access the sheet for a specific product.

We have built a number of aggregated products now so the feature is considered stable. It is however, probably naturally, more complex to setup than a single product.

I hope that helps. Let us know how you get on.

Regards,
Richard.

2016-04-14 15:54:02
Bugs during Installation on server Ubuntu 10.04.4
Category: User Forums

Hi, Everything looks normal in your log up to the line below. I've not seen a deployment fail this way but I'd suggest (clutching at straws a bit) that there may be a file corruption or a permissions issue - the latter seems less likely. I'd try a clean install as a first step. We deploy quite regularly to Ubuntu, so you should face any compatibility issues.

03/04/16 14:58:49,242 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC00001: Failed to start service jboss.deployment.unit."ROOT.war".STRUCTURE: org.jboss.msc.service.StartException in service jboss.deployment.unit."ROOT.war".STRUCTURE: Failed to process phase STRUCTURE of deployment "ROOT.war"

Regards,
Richard.

2016-04-14 15:48:14
Installation
Category: User Forums

Hi,
Thanks for the post and your interest in OU.

Is there anything more in the log than exception? I'm suspecting that something else has failed earlier on in the process. Assuming that you still have the problem, if you attach a copy of your server.log (from [OU]/liferay*/jboss*/standalone/log). I'll take a closer look.

On the Java 8 front, I very much agree! At the moment we're constrained by liferay 6's dependency on 7. But once we move to liferay 7, that limitation will go away and we will be able to move to Java 8.

Kind regards,
Richard.

Thanks for the pointer on the java version. I'll update the page.

On your issue with getting a connection: Assuming that you are connecting from a remote box, you will need to make a config change to enable that. If you open the file [OU HOME]/liferay-portal-6.2.0-ce-ga1/jboss-7.1.1/standalone/configuration/standalone.xml, and search for "jboss.bind.address:127.0.0.1" (you'll find two occurrences) and replace them with "jboss.bind.address:0.0.0.0" then restart the OU and all should be well.

Out of the box the system binds to localhost as a secure default position - so that it isn't inadvertently left open.

Regards,
Richard.

2015-11-09 21:20:33
Category: User Forums

Hi Alessandro,

The my.cnf file can appear in different places depending on your installation, so /etc/my.cnf is fine.

However, the line itself must appear in the section of the file below the line: [mysqld]. Apologies that the readme didn't make that clear! I've updated our wiki page to cover it and I'll include it in the notes for the next release too.

Kind regards,
Richard.

2015-11-08 10:07:27
Category: User Forums

Hi Alessandro,
Ah! This is quite a common problem on Unix systems (other than MacOS). There is a note in the installation README.txt, but it is easily overlooked. I'll put it in an alert box in future to make it stand out:

If you are installing on a Linux based machine, edit /etc/my.cnf and add the following line to the [mysqld] section: 'lower_case_table_names = 1'



The best course is to add that setting, restart MySQL, and start OpenUnderwriter again. I don't believe that you'll need to reinstall OpenUnderwriter, but if you have made hand edits to the contents of tables (especially Liferay's tables like users_) you might want to delete the OpenUnderwriter databases and installation folder and do a clean install just to be sure.

Kind regards,
Richard.

2015-11-07 18:27:08
Category: User Forums

Hi Alessandro,
Welcome to the forums and thanks of the question.

Assuming that the installation has completed successfully, you will see a panel on the lower right of the page when you browse to 8080 showing a list of users (with silhouette icons above them). You can see an example if you browse to our demo site.

We include this panel (which you obviously wouldn't use on a production system!) just to make it easier to login as different types of user with different abilities.

If you don't see the panel, could you post a screenshot of what you do see?

Ta.,
Richard.

Hi Suresh,

That's an interesting error. My first thought is that that there is some problem caused by the path OpenUnderwriter is installed under. What folder do you have it installed in? Failing that, we'll have to enable some debugging in the .bat script to see what's really going on.

BTW I'm afraid that services like support over chat are something we can only offer as part of support contracts. We'll be happy to talk about that if it would help, but also happy to handle things here in the forums - albeit somewhat more slowly current/wink

Kind regards,
Richard.

Hi Suresh,

The MySQL site has some notes that should help you: http://dev.mysql.com/doc/mysql-windows- … -path.html

Ta.,
Richard.

  • Index
  • » Users
  • » dickanderson
  • » Profile

Connect

Get in touch with the team

     

OpenUnderwriter

Mocatta House
Trafalgar Place
Brighton
BN1 4DU
United Kingdom

Contact

 contact@openunderwriter.com
 +44 (0)20 7183 4578
 Contact form